Windows 10 | Mobile HotSpot| We (don’t) have a solution

Hello guys

Cannot get the mobile HotSpot fully functional on Windows 10? Were you searching for a single stop solution, then you are at a very wrong place(?) move on. We are going to discuss about a strange behavior associated with, else almost a perfect solution provided by Microsoft for tethering the available internet connectivity.

At our corporate LAN, we use two different sets of IP addresses. One provided by the ISP (front facing) and the Class C IP addresses for the domain member computers and other devices.

We had a sysadmin laptop that is configured to use internet without filtering (AKA Watch Guard Edge device) by letting the traffic through the ISP router & a Class C IP address for LAN connectivity. Most of the sysadmins use the same settings for ease and had some difficulties with this particular laptop.

Mobile HotSpot starts, however the connected devices do not get IP addresses issued and no internet connectivity. Resetting IP & Winsock and windows provided troubleshooters didn’t fix anything & on a “divine” call we decided to change the IP addresses used.

For example, We had

168.x.x.204/255.255.255.224 (ISP) and 131.x.x.46/24 (LAN, don’t frown, we had these public IP ranges used within the LAN, dating back to 1990s) for the single network interface which didn’t work for Mobile HotSpot, so we changed the ISP IP address with an IP from another set of readily available public IPs and viola! the Mobile HotSpot sprang to life immediately.

We did route table matches between both IP settings and couldn’t find any differences, however, the first setup completely failing to issue IP addresses & connectivity. As we failed do the maths, gave it a rest and started “enjoying” the internet. Yay! So if you are in the same situation and have spare IP addresses, give it a try.

regards,

rajesh

Advertisements